SELECT is not allowed in cluster mode #27713
Unanswered
AHulshoff
asked this question in
Q&A / Help
Replies: 2 comments 1 reply
|
tricky skip: set env or in .env-local maybe in your values.yml: |
0 replies
|
@AHulshoff Did you manage to solve this problem? But it didnt solve my issue |
1 reply
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Uh oh!
There was an error while loading. Please reload this page.
I tried to install Superset on kubernetes with the helm chart. As I already had a redis and postgres environment, I decided to reuse them. So I configured values.yml to use the correct parameters to setup the environments. But after deploying the helm chart, I found out that Superset is not working properly. After some investigation I found out that Superset worker is trying to start, but fails a little after with the following error message:
On Slack, I asked a similar question where someone thought it might be caused by the redis client not be configured to use a redis cluster. I have done some research and he might be right. If I look at the code of Superset, I cannot find a reference to redis cluster. Unfortunately, I am not an expert on using redis in python... Or redis in general for that matter. In other investigations I have done, I couldn't find any references to a similar problem. So I am not sure it is a bug and therefore I assume I made a mistake somewhere.
Both redis and postgres clusters are also running on kubernetes and are installed with the Bitnami helm charts.
My values.yml:
Can someone help me to solve this?
All reactions